Announcement

Collapse
No announcement yet.

Inno setup και windows 10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Inno setup και windows 10

    loading...
    Εγκατέστησα ένα καινούριο σύστημα windows 10, στη θέση των xp που είχα.
    Το inno setup μου κολλάει στα windows 10, αλλά δεν κέρω γιατί.
    Πάω να κάνω compile μία εφαρμογή μου -μιά στάνταρ εφαρμογή μου που δούλευε πάντα στα xp- και σταματάει και λέει "file acces denied".
    Φταίνε τίποτα administrator privileges ;
    Ή μήπως το antivirus ;
    Έχω βάλει το bitdefender free.
    Παλιά είχε Avast το οποίο το ξέρω ότι τα κάνει αυτά και έπρεπε να τους πεις "disable shields temorarily".
    Το AVG και άλλα δεν το έκαναν, να εμποδίζιουν το inno.
    Αλλά το bitdefender free δεν επιτρέπει να κάνεις "disable temporarily" - μόνο αν το απεγκαταστήσεις τελείως και το κάνεις remove.
    Παίζει όμως να το κάνει αυτό το πρόβλημα το antivirus ; Έχει υπ' όψιν του κανένας ;
    Ή παίζει να φταίει κάτι άλλο ;

    Δεν μπορώ να καταλάβω γιατί τα κάνουν αυτά.
    Το Avast ειδικά έχει τρελαθεί.
    Ότι file θες να κάνεις sharing το βγάζει virus και το μπλοκάρει !
    Μετράει λέει το "popularity index" και αν το popularity index είναι μικρό, το θεωρεί virus.
    Δηλαδή αν βάλω εγώ τα αυριανά διανυκτερεύοντα φαρκαμεία σε ένα cloud service μετά δεν κατεβαίνουν (που να το βρουν το popularity index !).

  • #2
    Προσπάθησε να αφαιρέσεις όλα τα ΑΝτιβαϊρους και να αφήσεις μόνο το ενσωματωμένο Windows Defender
    ΕΝ ΤΟ ΠΑΝ

    Comment


    • #3
      Το bit defender free έχει "shileds off" τελικά αλλά δεν έγινε τίποτα.
      Το έβαλα στο forum του Inno το ερώτημα αλλά το έβαλα στα "miscellaneous" και δεν το πρόσεξε κανένας. Τώρα το έβαλα πιό κεντρικά.
      Το ερώτημα μου είναι:

      I 'm migrating from XP to windows 10.
      My apps that I had compiled with Inno using XP seem to work, but in win10 I cannot run solutions.
      It stops with "access denied" - without any code number.
      I 'm trying a simple "hello world" program created with vb6.

      While using XP the Avast antivirus made things difficult and I had to temporarily switch off the protection shield every time. So later I changed to AVG which did n't do that.
      In win10 I use bitdefender free but when I tried with shields off the issue persisted, so it may as well be unrelated to the antivirus.

      What can I do about it ?

      Comment


      • #4
        Νομίζω έχει να κάνει με θέμα τα privileges που έχεις από τα εφτάρια ή τα vista και μετά για κάνε link μία το κώδικα κυρ παντελή μου.

        Comment


        • #5
          Originally posted by ronron View Post
          Νομίζω έχει να κάνει με θέμα τα privileges που έχεις από τα εφτάρια ή τα vista και μετά για κάνε link μία το κώδικα κυρ παντελή μου.
          Δε με λένε Παντελή. Εσένα πως σε λένε ; Μπάμια ;
          Ποιά privileges ακριβώς ; Έχω δύο directories. Το c:\myapps και το program files (x86)\vb6\mysourcefiles.
          Το exe το δημιουργεί η vb6 μέσα στο mysourcefiles και ο compiler υποτίθεται τα μαζεύει γενικώς.
          Τι privileges να ορίσω ; Κάτι όρισα αλλά δεν προχωράει.

          Comment

          Μηνύματα

          Collapse

          Θέματα

          Collapse

          Working...
          X